A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 08:32 AEDT
Update
We’re currently experiencing an issue with the Dashboard page not loading correctly after login due to the AWS Outage, as well as degraded site performance. Quick Fix: You can still access your account by updating your browser address to another page — for example: https://app.cartoncloud.com/[youraccount]/SaleOrders
From there, you’ll be able to navigate through the system as usual. Our team is working to resolve this as soon as possible — thank you for your patience!
Posted Oct 21, 2025 - 03:58 AEDT
Identified
The issue has been identified.
Posted Oct 21, 2025 - 03:19 AEDT
Investigating
We are are aware of an issue that is causing degraded performance due to an AWS Outage. Further updates will be provided through this banner.
Posted Oct 21, 2025 - 03:18 AEDT
This incident affected: Web Application Portal / APIs (Asia Pacific) and Web Application Portal / APIs (Americas).