Issues with Chrome
Incident Report for CartonCloud
Resolved
This incident has been resolved.
Posted 8 days ago. Jun 12, 2019 - 08:44 AEST
Identified
A Chrome update may be causing issues on some pages, if you experience any, please let us know asap: support@cartoncloud.com.au
Posted 13 days ago. Jun 07, 2019 - 19:43 AEST
Investigating
There's an issue occurring with a Google Chrome update that went out earlier today which is causing pages to create double-ups on orders. Please use either Firefox or Safari until this message has disappeared.
Posted 13 days ago. Jun 07, 2019 - 19:01 AEST
This incident affected: Web App.