We will perform a database upgrade on our North American environment on Sunday, 17 May at 10:00 PM ET (7:00 PM PT). This work is expected to take up to 2 hours. Users may remain logged in, however we recommend waiting until the maintenance window has completed for reliable system use. Please ensure any work is saved before the start time to avoid disruption.
Posted May 18, 2026 - 12:09 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 18, 2026 - 12:00 AEST
Scheduled
We will perform a database upgrade on our North American environment on Sunday, 17 May at 10:00 PM ET (7:00 PM PT). This work is expected to take up to 2 hours. Users may remain logged in, however we recommend waiting until the maintenance window has completed for reliable system use. Please ensure any work is saved before the start time to avoid disruption.
Posted May 18, 2026 - 10:04 AEST
This scheduled maintenance affected: Web Application Portal / APIs (Americas).