The schedule database upgrade in our North American environment has completed
Posted May 25, 2026 - 10:48 AEST
Verifying
Verification of the scheduled North American database maintenance is in progress
Posted May 25, 2026 - 10:24 AEST
In progress
We are performing a database upgrade on our North American environment on Sunday, 24 May at 7:00 PM ET (4:00 PM PT). This work is expected to take up to 2 hours. Users may remain logged in, however we recommend waiting until the maintenance window has completed for reliable system use.
Posted May 25, 2026 - 09:04 AEST
Scheduled
We will perform a database upgrade on our North American environment on Sunday, 24 May at 7:00 PM ET (4:00 PM PT). This work is expected to take up to 2 hours. Users may remain logged in, however we recommend waiting until the maintenance window has completed for reliable system use. Please ensure any work is saved before the start time to avoid disruption.
Posted May 24, 2026 - 11:52 AEST
This scheduled maintenance affected: Web Application Portal / APIs (Americas).